Forum

Teradata Express Ed...
 

Teradata Express Edition 14.10 converting from VMWare to VirtualBox  

  RSS

Roland Wenzlofsky
(@rwenzlofsky)
Estimable Member
Joined: 6 years ago
Posts: 203
21/04/2014 7:22 pm  

The Teradata Express Edition is an excellent opportunity to play around with a fully equipped  Teradata System. It is available for download at http://downloads.teradata.com/download/database

Unfortunately, the only supported virtualization software is VMWare. Being a user of Oracle's VirtualBox virtualization software, I was searching for a possibility to convert the VMWare images to VirtualBox images.

After unpacking the zip file containing the Teradata Express Edition 14.10, you will find the three files needed by VMWare:
sda.vmdk, PDISK0.vmdk and PDISK1.vmdk
Changing the file format from VMWare to VirtualBox is quite easy. The conversion process was tested with VirtualBox 4.3.10.

All you have to do is:

- Open a Windows shell (run the cmd command)
- change the current directory to the place where your VirtualBox software is installed, in my case this is:

cd C:Program FilesOracleVirtualBox

- Run the conversion program which is part of the VirtualBox installation. You have to convert the Linux installation and both virtual disks (VDISKs); {PATH} has to point to the directory where you have unpacked the Teradata Express Edition files:

VBoxManage {PATH}sda.vmdk  {PATH}sda.vdi --format VDI
VBoxManage {PATH}PDISK0.vmdk  {PATH}PDISK0.vdi --format VDI
VBoxManage {PATH}PDISK1.vmdk  {PATH}PDISK1.vdi --format VDI

These commands create the VirtualBox images which now can be directly added to Virtual Box. Be aware, that these converted images are considerably bigger than the original VMware images. In my case, the original files have been about 11 GB, after conversion they were altogether more than 31 GB in size.

After this conversion process, I was able to install the  Teradata Express Edition 14.10 from Virtual Box without any problems.

If you have any further questions regarding the conversion and installation process, feel free to ask.

This topic was modified 7 days ago by DWH Pro Admin

Quote
hitit lidya
 hitit lidya
(@hitit lidya)
Guest
Joined: 5 years ago
Posts: 1
15/03/2015 11:45 pm  

Hi Roland,

Thanks for your post.

I think the convertfromraw command is missing in the post.
VBoxManage convertfromraw {PATH}sda.vmdk {PATH}sda.vdi –format VDI.

Even after converting VMDKs to VDIs, and creating a new Linux 64 bit VM I cannot seem to get it working. I am keep getting the "FATAL: Could not read from the boot medium! System halted." message.

The way I am doing this is:
1. Create a Linux VM (tried selecting openSuse or other Linux 64 bit while creating) with no hard-drives
2. Add the 3 Teradata VDIs to the VM

Any hints will be appreciated.

Thanks,
Hitit


ReplyQuote
Nait
 Nait
(@Nait)
Guest
Joined: 4 years ago
Posts: 1
04/03/2016 4:44 pm  

I struggled to make TD-Express work in a VirtualBox environment as well until I found the fundamental flaw in my approach (after scrutinizing the vmx file provided in the download). Here are the steps I took to make TD-Express work with VB:

Latest Virtualbox install:
http://download.virtualbox.org/virtualbox/5.0.14/VirtualBox-5.0.14-105127-OSX.dmg
Latest TD-Express version (TDE 15.10.0.07 SLES 11 for VMware (40GB) w/Viewpoint):
http://downloads.teradata.com/download/license?destination=download/files/7671/196626/0/TDExpress15.10.0.7_Sles11_40GB_vp.7z&message=License%2520Agreement
Virtualbox config:
By default VB sets up the disks as SATA
The TD-Express vmdk’s require SCSI
Steps to configure SCSI
Open VB
Create a new VM
Name: TD-Express
Type: Linux
Version: openSUSE (64-bit)
Memory size: Greater than 1GB
Hard disk: Do not add a virtual disk
Once created
Click “Storage” in the VB Manager
NOTE: Below steps can be performed with icons on the bottom of manager window
Delete “Controller: SATA”
Add “SCSI Controller”
Add “hard disk”
Choose existing disk
Select "TDExpress15.10.0.7_Sles11_40GB_vp-disk1.vmdk” from the location you unzipped the TD- Express download
Repeat for *disk2, *disk3
Click OK
Start virtual from VB Manager window!


ReplyQuote
victor
 victor
(@victor)
Guest
Joined: 3 years ago
Posts: 1
08/10/2016 6:25 pm  

Hi I followed the instructions, but I get only command line mode , not like windows OS and desktop icons.. What do i need to wok it like windows.


ReplyQuote
shankar
 shankar
(@shankar)
Guest
Joined: 3 years ago
Posts: 1
17/11/2016 10:47 am  

Hi,
we followed the above metion steps for istalling oracelbox and tdexpress but stil when i start the virtual mahcine its stopping at the below line

Console: VGA + 80*25

and virtual linux instance has to open login popup windows which is not happenning

Thanks,
Shankar


ReplyQuote
Paul Hernandez
 Paul Hernandez
(@Paul Hernandez)
Guest
Joined: 3 years ago
Posts: 4
21/12/2016 10:25 am  

Hi Shankar,

I was facing the same situation and it could be very frustraiting. I converted the image using ovftool from VMWare and also tried to attached the vm directly changing the Controller type and my vm always stuck on the same point as you with this irrelevant VGA text.

The solution was to change the virtualization in the system settings --> accelaration tab to "Hyper-V" and that did the trick.

I hope that helps.

Kind regards,

Paul


ReplyQuote
Share:
>

Please Login or Register